Apa itu gdm3, kdm, lightdm pada Linux?



Manajer tampilan adalah program yang menyediakan login grafis kemampuan untuk Sistem X Window. Hanya satu pengelola tampilan yang dapat mengelola X server tertentu, tetapi banyak paket manajer tampilan diinstal. Silakan pilih tampilan mana manajer harus dijalankan secara default. 

Beberapa manajer tampilan dapat berjalan secara bersamaan jika dikonfigurasi untuk mengelola server yang berbeda. Untuk mencapai ini, konfigurasikan tampilan manajer sesuai, edit setiap skrip init mereka di /etc/init.d, dan nonaktifkan pemeriksaan untuk manajer tampilan default.

gdm3

gdm3 adalah penerusnya gdm yang merupakan manajer tampilan GNOME. Yang lebih baru gdm3 menggunakan versi minimal gnome-shell, dan memberikan tampilan dan nuansa yang sama seperti sesi GNOME3. Merupakan pilihan Canonical sejak Ubuntu 17.10. Anda dapat menginstalnya dengan:

sudo apt-get install gdm3
dan hapus dengan:

sudo apt-get remove gdm3

kdm

kdm adalah manajer tampilan KDE. Tapi itu sudah ditinggalkan di KDE5 yang mendukung SDDM, yang lebih mampu sebagai manajer tampilan, dan karenanya datang secara default dengan Kubuntu. Anda dapat menginstalnya dengan:

sudo apt-get install sddm 
dan hapus dengan:

sudo apt-get remove sddm

LightDM

LightDM adalah solusi Canonical untuk manajer tampilan. Seharusnya ringan dan datang secara default dengan Ubuntu, Xubuntu, dan Lubuntu. Ini dapat dikonfigurasi, dengan berbagai tema login yang tersedia.

Anda dapat menginstalnya dengan:

sudo apt-get install lightdm
Dan hapus dengan:

sudo apt-get remove lightdm

Memilih Manajer Tampilan

sudo dpkg-reconfigure gdm3

Anda dapat menggunakan nama manajer tampilan apa pun gdm3 di dalam perintah di atas, dan itu akan memungkinkan Anda untuk memilih di antara mereka. Anda harus mem-boot ulang agar perubahan dapat diterapkan

Memeriksa manajer tampilan yang digunakan, gunakan perintah berikut ini:

cat /etc/X11/default-display-manager

Desktop Environment Terbaik Untuk Linux

Pada Sistem Operasi, sebuah lingkungan desktop (desktop environment) adalah grafis antarmuka pengguna yang berbasis Grafik (GUI) dengan tampilan layar komputer modern. Desktop Environment adalah alternatif sebagai pengganti antarmuka berbasi text/CLI. Dengan Dekstop Environment menyebabkan Sistem Operasi Linux sekarang ini sudah tidak dianggap sistem operasi yang susah. Desktop environment sudah menyediakan tampilan grafis dan animasi layaknya sistem operasi Windows dan Mac OS. Berikut ini beberapa contoh desktop environment yang dapat digunakan di sistem operasi linux, yaitu : 

KDE


KDE adalah salah satu lingkungan desktop paling populer di luar sana. Anda juga bisa menyebutnya sebagai desktop " Plasma ". Desktop Environment ini sangat mudah disesuaikan dan sangat ringan.

KDE telah berhasil mengalahkan XFCE sebagai salah satu lingkungan desktop paling ringan. Tidak hanya terbatas pada pengujian, Anda akan menemukan banyak perbandingan dan tes benchmark yang mengarah ke hasil yang sama.

KDE juga memudahkan untuk menghubungkan telepon Anda dengan sistem Linux Anda menggunakan KDE Connect. Anda juga akan menemukan integrasi browser Plasma yang menghubungkan telepon Anda langsung ke browser Anda untuk membangun komunikasi cepat.

Secara keseluruhan, KDE adalah lingkungan desktop yang sangat ringan sekaligus menjadi salah satu yang paling fleksibel.

Beberapa distro Linux yang menggunakan KDE sebagai default adalah openSUSE , Kubuntu dan KDE Neon. 

Kelebihan : 
  1. Antarmuka pengguna yang modern dan halus
  2. Pengalaman yang sangat dapat disesuaikan dan fleksibel
  3. Beberapa alat yang berguna ada di dalamnya
  4. Sangat ringan
Kekurangan :
  1. Pengaturan dan tool sedikit terlalu berlebihan untuk pemula, menyebabkan potensi kebingungan.


MATE


Lingkungan Desktop MATE didasarkan pada GNOME 2. MATE pada awalnya dikembangkan untuk pengguna yang kecewa dengan GNOME 3.

Meskipun ini didasarkan pada GNOME 2 yang bagus, tim MATE telah meningkatkan lingkungan desktop dengan banyak alasan. Untuk mendapatkan beberapa ide, Anda mungkin ingin melihat apa yang ditawarkan Ubuntu MATE 20.04 .

Jika kita mengambil contoh Ubuntu MATE 20.04, desktop MATE cocok untuk hampir semua orang. Dan, tentunya, terutama bagi mereka yang menyukai GNOME 2. Selain pengalaman pengguna, perlu juga dicatat bahwa ini adalah lingkungan desktop yang ringan.

MATE hadir dengan kumpulan aplikasi dasar dan sejumlah tool bawaan.

Ubuntu MATE adalah salah satu versi resmi Ubuntu yang menggunakan desktop MATE. Beberapa distribusi Linux populer lainnya seperti Linux Mint, Manjaro, dll, juga menawarkan edisi MATE dari distro mereka.

Kelebihan : 
  1. Pengalaman yang mudah digunakan dan tangguh
  2. Ringan
  3. Sederhana namun Dapat Disesuaikan
Kekurangan : 
  1. Tidak menawarkan pengalaman pengguna yang paling intuitif

GNOME


GNOME bisa dibilang adalah lingkungan desktop paling populer. Banyak distro Linux populer menggunakan GNOME sebagai lingkungan desktop default mereka dan memiliki beberapa distro populer, seperti Cinnamon .

GNOME dirancang agar mudah digunakan dan dapat disesuaikan. Antarmuka pengguna bertujuan untuk memberikan pengalaman unik (jenis yang disesuaikan untuk seluler dan desktop).

Sayangnya, GNOME bukanlah lingkungan desktop yang ringan. Jadi, ini bukan pilihan yang bagus jika Anda ingin menginstal distribusi Linux pada komputer lama atau sistem dengan RAM kurang dari 4 GigaByte.

Beberapa distro besar yang menggunakan GNOME adalah Debian ,  Fedora , openSUSE ,  dan Ubuntu serta Pop OS 20.04.

Kelebihan : 
  1. UI modern dan ramah sentuhan
  2. Dapat memperluas fungsionalitas melalui Ekstensi Shell GNOME
  3. Dapat disesuaikan
Kekurangan : 
  1. Tidak cocok untuk komputer lama
  2. Antarmuka Pengguna tidak disesuaikan untuk pengguna Windows

Cinnamon


Cinnamon adalah sebuah cabang dari GNOME 3, pada awalnya dikembangkan menjadi lingkungan desktop default untuk  Linux Mint. Cinnamon dikenal karena kemiripannya dengan antarmuka pengguna Windows yang membantu pengguna Linux baru merasa nyaman menggunakan dengan mudah.

Cinnamon mencoba menampilkan lingkungan desktop modern sambil menawarkan antarmuka pengguna tradisional. Dan, karena sumber daya yang sedikit membuat Cinnamon menjadi pilihan yang seimbang bagi banyak pengguna Linux.

Kelebihan : 
  1. Tampilan ramping dan halus
  2. Antarmuka yang familier
  3. Cukup bisa disesuaikan
Kekurangan : 
  1. Mungkin tidak menawarkan pengalaman pengguna yang paling intuitif

Budgie


Budgie adalah desktop environment yang dikembangkan oleh proyek Solus. Solus adalah distro Linux yang dikembangkan secara independen di mana mereka memanfaatkan teknologi GNOME seperti GTK untuk mengembangkan lingkungan desktop Budgie.

Ini adalah bentuk campuran dari UI modern dan antarmuka pengguna tradisional. Tidak memerlukan sumber daya yang berat tetapi juga bukan lingkungan desktop ringan yang lengkap.

Ubuntu Budgie resmi versi Ubuntu yang menampilkan desktop Budgie sebagai default tampilannya. Sedikit distro linux yang mendukung lingkungan desktop Budgie. Jadi, Anda lebih baik menggunakan Solus atau Ubuntu Budgie untuk menggunakan Desktop Environment Ini.

Kelebihan : 
  1. Solid dan intuitif
  2. UI modern, tampilan elegan
  3. Pengalaman desktop yang mulus
Kekurangan
  1. Hanya tersedia di beberapa distribusi

LXQt


LXQt adalah lingkungan desktop Qt yang ringan. Jika dibandingkan dengan LXDE , dapat dikatakan bahwa LXQt memang lingkungan desktop yang ringan sekaligus memberikan pengalaman pengguna yang lebih baik daripada LXDE.

Tidak hanya secara teoritis, tetapi kami juga menganggapnya sebagai pengganti yang bagus untuk LXDE di Lubuntu 20.04 .

Meskipun LXQt mencoba menghadirkan tampilan modern tanpa memengaruhi performa, ini tetap bukan tampilan yang paling bagus. Tentu saja, jika Anda membutuhkan performa di atas tampilan dan nuansa, LXQt adalah pilihan yang baik.

Kelebihan
  1. Kinerja sangat cepat dan ringan
  2. UI yang layak untuk lingkungan desktop yang ringan
Kekurangan
  1. Tidak menarik
  2. Tidak banyak yang bisa disesuaikan
  3. Hanya tersedia di beberapa distribusi

Xfce


Xfce adalah salah satu lingkungan desktop paling ringan yang pernah ada. Tidak seperti LXQt, Anda akan menemukan banyak distribusi Linux utama mendukung edisi XFCE.

Xfce ringan pada sumber daya tetapi terbukti memberikan pengalaman pengguna yang kaya fitur. Jika Anda membutuhkan lingkungan desktop yang mengutamakan kinerja tanpa perlu penyesuaian lanjutan, Xfce adalah pilihan yang tepat.

Sebagai contoh, pada Zorin OS 15 Lite yang menyertakan lingkungan desktop Xfce sebagai default.

Distribusi Linux utama seperti Manjaro Linux , Xubuntu , MX Linux , Zorin OS Lite , dan beberapa lainnya menampilkan Xfce sebagai lingkungan desktop default.

Kelebihan
  1. Ringan dan mudah beradaptasi dengan perangkat keras lama
  2. Modern dan menarik secara visual
  3. UI familiar mirip Windows
Kekurangan
  1. Tidak ada kustomisasi lanjutan

Deepin


Terkadang tidak cukup untuk menawarkan opsi penyesuaian atau sumber daya yang ringan. Ada banyak pengguna yang lebih memilih antarmuka pengguna yang menarik dengan mengorbankan kinerja lingkungan desktop.

Saat itulah lingkungan desktop Deepin muncul. Ini mungkin menawarkan antarmuka macOS, tetapi karena animasi dan tata letaknya, tampilan dan nuansa lingkungan desktop Deepin adalah sesuatu yang dihargai.

Awalnya, ini hanya tersedia di Deepin OS , tetapi sekarang secara bertahap ditambahkan ke beberapa distro lain. Baru-baru ini sebuah proyek yang menarik telah berhasil memasukkan Deepin ke dalam Ubuntu. Deepin dapat diadopsi oleh distribusi Linux lainnya.

Kelebihan : 
  1. Antarmuka pengguna eye candy
  2. Animasi yang ramping
Kekurangan : 
  1. Berat pada penggunaan sumber daya dan kadang lamban

Apa itu LTS, Desktop, Server, Remix dan Alternate?


Linux adalah sistem operasi open source. Sistem operasi ini sekarang sudah tidak dikenal lagi seperti sistem operasi yang menggunakan basis text dalam pengoperasiaonnya. Tetapi sekarang sudah banyak sistem operasi linux yang menggunakan GUI yang baik dan dilengkapi dengan animasi layaknya sistem operasi windows dan machintos/mac os. 

Pada kesempatan ini saya membahas tentang sistem operasi ubuntu. Ada beberapa tipe sistem operasi ubuntu saat mereka mengeluarkan versi sistemnya. yaitu :

Ubuntu LTS (Long Term Support)
Ubuntu LTS adalah versi Ubuntu yang di support terhadap security dan update selama 3 tahun untuk desktop dan 5 tahun untuk server. 

Ubuntu Non-LTS 
Ubuntu Non-LTS adalah ubuntu yang di support oleh Cannonical selama 18 Bulan/1,5 Tahun.

Ubuntu Desktop
Ubuntu dengan versi GUI dan dilengkapi dengan live CD, sehingga sebelum melakukan instalasi kita dapat mencoba tampilan GUI sebelum diinstalasi.

Ubuntu Server
Ubuntu server adalah sistem operasi yang digunakan untuk server dan berbasis text. Di dalam sistem operasi ini sudah dilengkapi dengan aplikasi server seperti Apache, PHP dan Mysql Server. 

Ubuntu Remix
Ubuntu yang dirancang khusus untuk netbook

Ubuntu Alternate
Ubuntu Versi GUI tetapi tidak menyediakan live CD, Jika ingin mencoba sistem operasinya harus melakukan instalasi langsung. 

Cara Menghubungkan Google Drive Dengan Linux

Langkah - langkah nya
1. Pilih Pengaturan
2. Klik Akun daring
3. Klik Google dan isi user email dan sandi


4. Ijinkan Semuanya


5. Sudah Terkoneksi tinggal Tutup


6. Sudah Masuk 1 akun lagi
7. Buka Aplikasi Berkas

8. Klik Email yang kita masukkan, Selamat Anda sudah berhasil



Menampilkan Layar Android Di Linux dengan scrcpy



1. Koneksi Internet

2. Install Snapd

sudo apt install snapd

3. Start Snapd

systemctl start snapd.service


4. Cek Status Snapd

systemctl status snapd.service


5. Cek Version Snapd

snap version


6. Install scrcpy

snap install scrcpy


7. Install ADB

sudo apt-get install android-tools-adb


8. Cek Device


adb devices


9. SCRCPY


scrcpy




SETINGAN MIKROTIK UNTUK DIRUMAH




BLOK UPDATE

/ip firewall layer7-protocol add name=BLOK regexp="^.+(.download.w
indowsupdate.com|.ntservicepack.microsoft.com|.update.microsoft.com|.windowsupdate
.com|.windowsupdate.microsoft.com|.ws.microsoft.com|.stats.microsoft.com|.download
.microsoft.com|.wustat.windows.com|.stats.microsoft.com|download.windowsupdate.com
|ntservicepack.microsoft.com|update.microsoft.com|windowsupdate.com|windowsupdate.
microsoft.com|ws.microsoft.com|stats.microsoft.com|download.microsoft.com|wustat.w
indows.com|stats.microsoft.com).*\$"

/ip firewall filter add chain=forward action=drop layer7-protocol
=BLOK log=yes log-prefix="Windows_Update_Block"


PEMBAGIAN BANDWITH DENGAN QUEUE TREE

/ip firewall mangle add chain=forward dst-address=192.168.0.1/24 a
ction=mark-packet passthrough=no new-packet-mark=down_user comment="Download User"    

/ip firewall mangle add chain=forward src-address=192.168.0.1/24 a
ction=mark-packet passthrough=no new-packet-mark=upl_user comment="Upload User"
/queue type add name=pcq_down kind=pcq pcq-classifier=dst-address,
dst-port
/queue type add name=pcq_upl kind=pcq pcq-classifier=src-address,
src-port
 /queue tree add name=Download parent=KONEKSI max-limit=100M queue
=default
/queue tree add name=user_download parent=Download packet-mark=do
wn_user limit-at=20M max-limit=100M queue=pcq_down
/queue tree add name=Upload parent="1. SW ICT" queue=default max-
limit=10M
/queue tree add name=user_upload parent=Upload packet-mark=upl_us
er queue=pcq_upl limit-at=5M max-limit=10M


Instalasi Ionic Di Linux


Ionix adalah bahasa pemrograman untuk membuat aplikasi Android, IOS dan Windows Phone Langsung dengan 1 Aplikasi. Ionix di buat menggunakan Text Editor layaknya website. Bahasa pemrogramanya juga menggunakan website.

Langkah - Langkah Instalasi 

1.Instalasi NPM

NPM adalah aplikasi yang akan digunakan untuk mendownload aplikasi Cordova dan Ionic
$ sudo apt-get install npm

2. Instalasi Cordova

Instalasi server Cordova yang akan menjalankan aplikasi ionic

$ sudo npm install -g cordova

3. Instalasi Ionic

Instalasi Aplikasi Ionic

$ sudo npm install -g ionic

4. Membuat Folder

Forder untuk menyimpan file ionic

$ cd ~
$ mkdir app1
cd app1

5. Download Ionic

Download langsung dari web ionic sesuai keinginan

$ ionic start todo blank --type ionic1

6. Menjalankan Ionic

$ ionic serve